]> git.pld-linux.org Git - packages/dbus-c++.git/blob - dbus-c++.spec
- new, based on fedora
[packages/dbus-c++.git] / dbus-c++.spec
1 Summary:        Native C++ bindings for D-Bus
2 Name:           dbus-c++
3 Version:        0.9.0
4 Release:        0.1
5 License:        LGPL v2+
6 Group:          Libraries
7 URL:            http://sourceforge.net/projects/dbus-cplusplus/
8 Source0:        http://downloads.sourceforge.net/dbus-cplusplus/lib%{name}-%{version}.tar.gz
9 Patch1:         %{name}-gcc4.7.patch
10 Patch2:         %{name}-linkfix.patch
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  dbus-devel
15 BuildRequires:  ecore-devel
16 BuildRequires:  expat-devel
17 BuildRequires:  glib2-devel
18 BuildRequires:  gtkmm-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 dbus-c++ attempts to provide a C++ API for D-Bus. The library has a
23 glib/gtk and an Ecore mainloop integration.
24
25 %package        devel
26 Summary:        Development files for %{name}
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29 Requires:       pkgconfig
30
31 %description    devel
32 This package contains libraries and header files for developing
33 applications that use %{name}.
34
35 %prep
36 %setup -q -n lib%{name}-%{version}
37 %{__sed} -i 's/\r//' AUTHORS
38 %patch1 -p1
39 %patch2 -p1
40
41 %build
42 %{__libtoolize}
43 %{__aclocal}
44 %{__autoconf}
45 %{__automake}
46 %configure \
47         --disable-tests
48
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %doc COPYING AUTHORS
68 %attr(755,root,root) %{_bindir}/dbusxx-introspect
69 %attr(755,root,root) %{_bindir}/dbusxx-xml2cpp
70 %{_libdir}/*.so.*
71
72 %files devel
73 %defattr(644,root,root,755)
74 %doc TODO
75 %{_includedir}/*
76 %{_libdir}/*.so
77 %{_pkgconfigdir}/*
This page took 0.048226 seconds and 3 git commands to generate.